Keresés

Új hozzászólás Aktív témák

  • Cirbolya_sen

    aktív tag

    válasz kovyhun #5636 üzenetére

    Ez no-ip-s script, ami neked van :D

    dyndns script:

    #DynDns mikrotik config
    :global ddnsuser "xxxxxxx"
    :global ddnspass "xxxxx"
    :global theinterface "pppoe-out1"
    :global ddnshost xxxxx.dyndns.org
    :global ipddns [:resolve $ddnshost];
    :global ipfresh [ /ip address get [/ip address find interface=$theinterface ] address ]
    :if ([ :typeof $ipfresh ] = nil ) do={
    :log info ("DynDNS: No ip address on $theinterface .")
    } else={
    :for i from=( [:len $ipfresh] - 1) to=0 do={
    :if ( [:pick $ipfresh $i] = "/") do={
    :set ipfresh [:pick $ipfresh 0 $i];
    }
    }

    :if ($ipddns != $ipfresh) do={
    :log info ("DynDNS: IP-DynDNS = $ipddns")
    :log info ("DynDNS: IP-Fresh = $ipfresh")
    :log info "DynDNS: Update IP needed, Sending UPDATE...!"
    :global str "/nic/update\?hostname=$ddnshost&myip=$ipfresh&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG"
    /tool fetch address=members.dyndns.org src-path=$str mode=http user=$ddnsuser \
    password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
    :delay 1
    :global str [/file find name="DynDNS.$ddnshost"];
    /file remove $str
    :global ipddns $ipfresh
    :log info "DynDNS: IP updated to $ipfresh!"
    } else={
    :log info "DynDNS: dont need changes";
    }
    }

    mi van beállítva "time server"-nek?
    Google, vagy time.kfki.hu szokott nálam a routerekben benne lenni

    [ Szerkesztve ]

    Cirbolya_sentinel

  • ekkold

    Topikgazda

    válasz kovyhun #5636 üzenetére

    Az IP Cloud menüben kapcsold ki az idő frissítését, és csak időszerverhez állítsd be az időt.
    /system clock set time-zone-name=Europe/Budapest
    /system ntp client set enabled=yes primary-ntp=148.6.0.1 secondary-ntp=52.178.161.41

Új hozzászólás Aktív témák