-
Fototrend
Mikrotik routerekkel foglalkozó téma. Mikrotik router típusok, hardverek, router beállítások, programozás (scriptek írása), frissítés, és minden Mikrotik routerrel kapcsolatos beszélgetés helye.
Új hozzászólás Aktív témák
-
kovyhun
tag
válasz
byson55 #8725 üzenetére
Szia,
én ezt használom:
# Script to forward SMS from GSM Modem Inbox to Email #
# Note: The SMS is removed from the inbox after being sent to Email, #
# even if the Email fails to be sent #
# Remember to set up /Tools/SMS with the USB port of your #
# Modem and the info channel. Put anything in secret and #
# make sure Receive Enabled is ticked #
# Tested on Rb751U RouterOS v5.12 with Huawei E367 #
# Peter James 2012-04-04 #
:local EmailAddress "your_email_address";
:local smsPhone;
:local smsTimeStamp;
:local smsMessage;
:local smsContent;
# Get System Identity #
:local SystemID [/system identity get name];
:log info "SMS to Email script started";
# Set Receive Enabled, in case it was cleared by a router reboot #
/tool sms set receive-enabled=yes;
delay 2;
# loop through all the messages in the inbox #
:foreach i in=[/tool sms inbox find] do={
:set smsPhone [/tool sms inbox get $i phone];
:set smsTimeStamp [/tool sms inbox get $i timestamp];
:set smsMessage [/tool sms inbox get $i message];
:set smsContent "Router ID: $SystemID\nSMS Received from: $smsPhone\nDate&Time: $smsTimeStamp\nMessage: $smsMessage";
:log info $smsContent;
/tool e-mail send tls=yes subject="$SystemID GSM Modem SMS Received" to=$EmailAddress body="$smsContent";
# Now remove the SMS from the inbox #
/tool sms inbox remove $i;
delay 10;
}
# clear Receive Enabled, so info channel can be used by other scripts #
/tool sms set receive-enabled=no;
:log info "SMS to Email script complete";(Nem engedi ez az új fórum programkódba formázni)
Új hozzászólás Aktív témák
- gban: Ingyen kellene, de tegnapra
- Luck Dragon: Asszociációs játék. :)
- Linux haladóknak
- Apple asztali gépek
- Milyen légkondit a lakásba?
- Azonnali alaplapos kérdések órája
- Intel Core i5 / i7 / i9 "Alder Lake-Raptor Lake/Refresh" (LGA1700)
- LEGO klub
- Nintendo Switch 2
- Hálózatokról alaposan
- További aktív témák...
- ÚJ, BONTATLAN Honor 200 Lite 256GB - GYÁRI GARANCIA 2026 novemberig
- Lenovo T495 14" AMD Ryzen 7 3700U 16GB 250GB SDD laptop notebook eladó
- ÚJ ASUS Zenbook 14 Laptop Ultrabook -40% Ultra 7 155H 16GB/1TB 3K OLED 120Hz Intel Arc
- Lenovo Yoga Slim 7 Pro 16ACH6 R7 5800H 16GB RAM 512GB SSD RTX3050 16" Win10
- Eladó Ubiquiti Unifi USG-3P Gateway Router 2db!
- Lenovo ThinkCentre M720q / M920q Tiny mini PC- 8.gen Win11- Számla/garancia
- AKCIÓ! GIGABYTE B550M R7 5800X 32GB DDR4 512GB SSD STRIX RTX 2060 Super 8GB Zalman S2 TG MSI650
- Egyedi ékszerdobozka
- SEAGATE ST6000NM0034 6TB 7.2k SAS HDD, nettó 15747Ft + ÁFA, 1 év garancia
- AKCIÓ! Gigabyte B450M R7 2700 16GB DDR4 512GB SSD RX 6600 8GB GDDR6 CM MasterBox 5 Lite 600W
Állásajánlatok
Cég: PCMENTOR SZERVIZ KFT.
Város: Budapest